Za chwilę zostaniesz przekierowany do nowej (lepszej!) odsłony bloga ABC Excel.

czwartek, 23 maja 2013

Funkcja LICZ.JEŻELI

W dzisiejszym wpisie opiszę funkcję LICZ.JEŻELI. Zapraszam wszystkich do lektury i dziękuję, że jesteście ze mną :)


Funkcja LICZ.JEŻELI jest bardzo przydatna podczas pracy w programie Excel. Jej zadaniem jest podanie ilości komórek z podanego przez nas zakresu, które spełniają zdefiniowane przez nas kryteria.

Składnia to:

=LICZ.JEŻELI(zakres;kryteria)

  • zakres - badany przez ciebie zakres komórek
  • kryteria - warunek, który musi spełniać komórka, by być policzona przez funkcję

Przykłady formuł wraz z ich zastosowaniem:


  • =LICZ.JEŻELI(A1:A10;">4") - zlicza liczbę komórek z zakresu od A1 do A10, których wartość jest większa od 4
  • =LICZ.JEŻELI(A1:A10;">=4") - zlicza liczbę komórek z zakresu od A1 do A10, których wartość jest większa lub równa od 4
  • =LICZ.JEŻELI(A1:A10;"<>4") - zlicza liczbę komórek z zakresu od A1 do A10, których wartość jest różna od 4
  • =LICZ.JEŻELI(A1:A10;">"&E5) - zlicza liczbę komórek z zakresu od A1 do A10, których wartość jest większa od zawartości komórki E5
  • =LICZ.JEŻELI(A1:A10;"<>"&E5) - zlicza liczbę komórek z zakresu od A1 do A10, których wartość jest różna od zawartości komórki E5
  • =LICZ.JEŻELI(A1:A10;E5) - zlicza liczbę komórek z zakresu od A1 do A10, których wartość jest równa od zawartości komórki E5 (może to być zarówno liczba jak i słowo)
  • =LICZ.JEŻELI(A1:A10;"sprzedaż") - zlicza liczbę komórek z zakresu od A1 do A10, których zawartość to słowo sprzedaż (wielkość liter nie ma znaczenia)
  • =LICZ.JEŻELI(A1:A10;"*sprzedaż*") - zlicza liczbę komórek z zakresu od A1 do A10, które zawierają słowo sprzedaż gdziekolwiek w komórce (gwiazdka zastępuje dowolne znaki)
  • =LICZ.JEŻELI(A1:A10;"sprzedaż*") - zlicza liczbę komórek z zakresu od A1 do A10, które rozpoczynają się od słowa sprzedaż
  • =LICZ.JEŻELI(A1:A10;"*aż") - zlicza liczbę komórek z zakresu od A1 do A10, które kończą się na aż
  • =LICZ.JEŻELI(A1:A10;"?????aż") - zlicza liczbę komórek z zakresu od A1 do A10, które kończą się na aż i składają się dokładnie z 7 liter (znak zapytania zastępuje dokładnie jedną literę)
  • =LICZ.JEŻELI(A1:A10;"*") - zlicza liczbę komórek z zakresu od A1 do A10, które zawierają teskt
  • =LICZ.JEŻELI(A1:A10; "<>"&"*") - zlicza liczbę komórek z zakresu od A1 do A10, które nie zawierają tekstu


Funkcji LICZ.JEŻELI nie używamy do:

  • Zliczania pustych komórek – służy do tego funkcja LICZ.PUSTE
  • Zliczania wszystkiego oprócz pustych komórek – służy do tego funkcja ILE.NIEPUSTYCH
  • Zliczania komórek zawierających liczby – służy do tego funkcja ILE.LICZB

Mam nadzieję, że te przykłady pomogą Wam w korzystaniu z funkcji LICZ.JEŻELI. Z góry dziękuję za wszystkie komentarze.

4 komentarze:

Adam Nowak pisze...

Dla zaawansowanych:

Funkcję LICZ.JEŻELI można "odejmować" i "dodawać".

=LICZ.JEŻELI(A1:A10;"<4")-LICZ.JEŻELI(A1:A10;"<=1") - zlicza liczbę komórek z zakresu od A1 do A10, które są mniejsze od 4 i odejmuje liczbę komórek mniejszych lub równych od 1. Wynikiem jest liczba komórek gdzie: 1 < x < 4

=LICZ.JEŻELI(A1:A10;"<4")+LICZ.JEŻELI(A1:A10;">15") - zlicza liczbę komórek z zakresu od A1 do A10, które są mniejsze od 4 i dodaje liczbę komórek większych od 15.

Dodaję to w komentarzu, bo Blogspot zwariował i nie chciał wyświetlić tego w poście.

Pozdrawiam - Adam

BSone pisze...

Przydatna funkcja :) dzięki za wszystkie wpisy które do tej pory zrobiłeś. Odwalasz kawał dobrej roboty i oby więcej:) w pracy zarażono mnie excelem jako hobby i teraz łaknę wiedzy ile się da:) A Twoja strona to nie mała jej ilość :) oby tak dalej:)

Anonimowy pisze...

Świetny blog, uwielbiam autora za to co robi! :)

Anonimowy pisze...

Witam

Już od dawna bloga śledzę - jest naprawdę dobry.
Jednak od kilku dni męczy mnie taki problem:
czy istnieje jakaś funkcja która umożliwia wyświetlenie sposobu działania w formie liczbowej np. mamy proste działanie: a1+b1= c1
w komórce a1 mam np. 2 w b1 2 więc w c1 mamy 4
chciałbym uzyskać zapis: 2+2=4 lub chociaż samo 2+2 jeśli się tak da....
Pozdrawiam
K.B

Prześlij komentarz

Uwaga: tylko uczestnik tego bloga może przesyłać komentarze.