Za chwilę zostaniesz przekierowany do nowej (lepszej!) odsłony bloga ABC Excel.

sobota, 15 maja 2010

Funkcje tablicowe

Witajcie w kolejnym poście bloga Abc Excel!

Dziś pokażę kolejną rzecz, która jest prosta jak abc.. a na pewno przyspieszy naszą pracę w programie Ms Excel.

Formuły obszarowe (lub też funkcje tablicowe) to takie, które nie odnoszą się do jednej komórki. Formuły obszarowe odnoszą się do obszaru komórek - na przykład tabelki z danymi.

Dziś nauczymy się, jak w jednej komórce obliczyć sumę obszaru komórek.

Przygotowałem prostą tabelkę z danymi sprzedaży.



Obliczmy sumę sprzedaży na podstawie tych danych. Wiemy już, jak działa funkcja SUMA, więc podstawy znamy.

Sumą sprzedaży w tym przypadku jest iloczyn ilości i ceny sprzedanych produktów - czyli musimy pomnożyć przez siebie ilości i ceny.



Funkcja suma powinna wyglądać w ten sposób: =SUMA(C6:C10*D6:D10). Funkcja jest gotowa. Wciskamy Enter i...


... pojawia się błąd! Coś nie działa!

Już tłumaczę. Błąd popełniliśmy zatwierdzając formułę Enterem. Excel nie wiedział, że stworzyliśmy funkcję obszarową. Do zatwierdzenia formuł obszarowych służy skrót klawiaturowy Ctrl + Shift + Enter.


Klikamy na formułę F2 (skrót klawiaturowy do edycji komórki) i wciskamy Ctrl + Shift + Enter.


Tym razem formuła obszarowa zadziałała i w jednej komórce obliczyliśmy sumę obszaru komórek.

Formuły obszarowe przydają się w pracy z Excelem i na pewno pojawią się jeszcze na blogu. Czytajcie Abc Excel i uczcie się Excela.

3 komentarze:

helmut pisze...

Tak samo zadziała też funkcja suma.iloczynów

ynwestor pisze...

Jako przykład już jutro na blogu pojawi się funkcja transponuj. Polecam!

joshi pisze...

Również jest to zastosowane w SUMA.JEŻELI

Prześlij komentarz

Uwaga: tylko uczestnik tego bloga może przesyłać komentarze.